HOME/組み込み製品/半導体IP/汎用IP/Classic IPsec ツールキット
セキュリティ

Classic IPsec ツールキット

ゲートウェイや組み込み機器向けIPsecソフトウェア。90以上のRFCに対応、FIPS 140-3モジュール統合可

メーカー Rambus Rambus
Classic IPsec ツールキット 製品画像
製品名
Classic IPsec ツールキット
スペシフィケーション
IPsec

概要・特徴

サーバーとクライアントがあらゆる種類のクライアント/サーバーデバイスと通信し、既存のゲートウェイと相互運用する必要がある場合に、関連するすべての(90以上)RFCおよび規格に対応した完全で高度にスケーラブルなIPsec実装です。Linuxデータプレーンはカーネル依存なしでサポートされており、高トラフィックゲートウェイや仮想環境への展開に最適です。
クラシックIPsecツールキット(Classic QuickSec)は、オプションでFIPS 140-3認証済みの暗号モジュールと統合可能で、物理および仮想クラウド/ネットワーク製品、プリンター、組み込みデバイスなどの主要ベンダーによって展開されています。

動作説明

Classic IPsec ツールキットの動作
お客様がさまざまな IPsec 実装とシームレスに動作する製品を開発する場合、Rambus IPsec ツールキットは、さまざまな種類の IPsec と連携するために必要な 90 以上の標準仕様をサポートしています。相互運用性は、Rambus の自社ラボでの QA プロセスの一環として検証されています。
高いスケーラビリティ
高いセッション設定レート。8 コア CPU で 1 秒あたり 4000 以上の IPsec トンネル確立が可能。マルチコアアーキテクチャで優れたスケーラビリティを発揮します。
トンネル数は、利用可能なコンピューティングリソースによってのみ制限されます。
高可用性 (HA):HA は、RFC 6311 に基づくネイティブクラスタリング実装、または IKE および IPsec SA のインポートおよびエクスポート用 API を使用して実現できます。
簡単なデバッグ。大規模展開時の問題解決のため、特定のトンネルの詳細ログを要求でき、パフォーマンスに影響を与えません
マルチテナント:複数のネットワークまたは複数のオペレーターをサポートするeNodeB向けに、独立したオーバーラップ可能な仮想ルーティングとフォワーディング(VRF)インスタンスをサポート
LinuxカーネルIPsecデータプレーンまたは同じAPIをサポートする他のデータプレーンと統合可能です。さらに、上位の共通データプレーンAPIにより、任意のIPsecデータプレーンとの統合が可能です
主要企業は、クラウド、SASE、SD-WAN、エンタープライズセキュリティゲートウェイ、高セキュリティ政府機関向けアプライアンス、高容量キャリアゲートウェイ、eNodeB、組み込みデバイス、プリンターなどの実装にIPsecツールキットを採用しています。

仕様

機能

  • 完全な IPsec および IKE クライアント/サーバー ツールキット
  • 高い相互運用性と標準準拠
  • アクティブ/スタンバイ クラスタリングによる高可用性
  • 市場最速の IKE 実装と、比類のないトンネル設定速度
  • スケーラビリティ:100 万以上の IPsec トンネルの展開に対応
  • FIPS 140-3 認証済みの暗号モジュールに対応
  • GPL の制約を受けない、明確で移植性の高い C ソースコードで記述
  • ルーティングインスタンスにより、マルチテナント環境でのトラフィックを分離
  • 幅広いハードウェアおよびソフトウェアプラットフォームをサポート
  • GPL ライセンスのオープンソースソフトウェアの、高品質な商用代替製品
  • メンテナンス契約に基づき、エンジニアレベルのサポートと定期的なアップデートを提供

IKE (インターネットキー交換) サポート

  • IKEv2 (RFC 7296)、IKEv2 フラグメンテーション (RFC 7383)、IKEv2 リダイレクト (RFC 5685)
  • 高可用性(RFC 6311)
  • MOBIKE(RFC 4555、RFC 4621)
  • IKEv1メインモードとアグレッシブモード
  • 完全前向秘密性(PFS)オプション
  • 再鍵交換、デッドピア検出(DPD)、NAT通過(NAT-T)
  • 認証:事前共有鍵(PSK)、XAUTH、証明書(フルPKIサポート)、拡張認証プロトコル(EAP-SIM、EAP-AKA、EAPMD5)、RADIUS、複数認証(RFC 4739)
  • IPv4 および IPv6 サポート:IPv4 over IPv6、IPv6 over IPv4、IPv6 over IPv6、DHCPv4 および DHCPv6
  • RSA、DSA および ECDSA 公開鍵アルゴリズム(IKE 署名モードのみ)
  • NIST 特別公開 800-131A に準拠した IKE における SHA2 対応の RSA 署名サポート
  • Diffie-Hellman 鍵交換アルゴリズム
  • FIPS 140-3 認証暗号化をオプションの商用オプションとして提供
  • リモートアクセスサポート: サーバーで構成された仮想アダプター
  • 組み込みの IP アドレス割り当て
  • 汎用 raw 公開鍵 (RFC 7670): RSA、DSA、ECDSA
  • 耐量子セキュリティのための IKEv2 での事前共有鍵の混合(RFC 8784)
  • IKEv2 アルゴリズム要件(RFC 8247)

証明書および PKI 機能

  • 509v3 (PKIX) 証明書プロファイルサポート
  • 509v3 (PKIX) 証明書失効リスト(CRL)サポート
  • LDAP および HTTP を使用した証明書配布ポイントのサポート
  • OCSP を使用したオンライン証明書ステータスチェック
  • NIST Special Pub. 800-131A に基づく、証明書における SHA2 に対する RSA 署名サポート+P12

完全な IPsec 暗号化

  • 暗号アルゴリズム:AES、AES-CCM、AES-GCM、AES-GCM-64、GMAC-AES、3DES
  • MAC アルゴリズム:SHA-1、SHA-2、GMAC-AES、AES-XCBC
  • 非対称暗号アルゴリズム:RSA、Diffie-Hellman、ECC DH、ECC DSA、PKCS#1、PKCS#5、PKCS#7、PKCS#8、PKCS#10、PKCS#12
  • 楕円曲線暗号: Brainpool 楕円曲線 (RFC 5639、RFC 6932)、ECDSA (RFC 4754)、ECP グループ (RFC 5903)、楕円曲線デジタル署名 (ECDS)

対応デバイス・対応OS

ベアメタル・各種OS

ライセンス形態

弊社にお問い合わせください。

評価版

弊社にお問い合わせください。

INQUIRY

Classic IPsec ツールキットに関する在庫、価格などの
お問い合わせはこちらから

フォームが表示されるまでしばらくお待ち下さい。

恐れ入りますが、しばらくお待ちいただいてもフォームが表示されない場合は、こちらまでお問い合わせください。

お急ぎの方はこちらから
050-3000-2102
平日:9:00〜17:00
CONTACT

まずは、ご相談ください。

「探している組み込み製品」も「相談したい組み込み開発」も、まずはこちらから。
“こんな製品はないか”、“見積もりがほしい”、“この技術は対応できるか”、“詳しい実績が知りたい”——質問だけでも結構です。
お急ぎの場合も迅速に対応します。

お電話でのお問い合わせ 050-3000-2102 インダストリービジネス事業部 平日:9:00〜17:00