HOME/組み込み製品/半導体IP/汎用IP/FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ)
セキュリティ

FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ)

組み込み機器向けソフトウェア暗号ライブラリ。FIPS 140-3 Level 1認証モジュールと暗号APIを提供

メーカー Rambus Rambus
FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ) 製品画像
製品名
FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ)
スペシフィケーション
AES

概要・特徴

Rambusの FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ)は、すべての主要な暗号アルゴリズムおよびプリミティブの最新の実装を提供する、最新の暗号ライブラリです。
FIPS 暗号ライブラリには、FIPS 認定の暗号モジュール、非 FIPS アルゴリズム用の標準暗号ライブラリ、および使いやすい統合用の暗号 API が含まれています。FIPS 暗号ライブラリは、IPsec ツールキットに統合され、1 億台以上のデバイスに導入されています。

動作説明

FIPS 140-3 暗号モジュール
FIPS 認定の暗号モジュールは、FIPS 暗号ライブラリのコアです。証明書およびセキュリティポリシーは、NIST のウェブサイトから入手できます:FIPS 140-3。
FIPS暗号モジュールは、FIPS 140-3セキュリティレベル1認証を取得したソフトウェア暗号モジュールです。このモジュールは、IPsec、VPN(仮想プライベートネットワーク)、TLS(トランスポート層セキュリティ)、DAR(データアットレスト)、DRM(デジタル権利管理)クライアントなどに必要な暗号プリミティブを含む、幅広いアプリケーションで最も一般的に使用される暗号プリミティブを提供するライブラリです。
この暗号モジュールは、他のRambus製品に必要な暗号機能を実装するために設計されています。ただし、カスタム開発製品において単独で使用し、必要な暗号機能を提供することも可能です。このモジュールは、汎用オペレーティングシステムを搭載した組み込み製品を主な対象としています。

仕様

サポートされるアルゴリズムおよび方式:

  • 暗号アルゴリズム:AES、AES-CCM、AES-GCM、AES-GCM-64、GMAC-AES、3DES
  • MAC アルゴリズム:SHA-1、SHA-2、GMAC-AES、AES-XCBC
  • 非対称暗号アルゴリズム:RSA、Diffie-Hellman、ECC DH、ECC DSA、PKCS#1、PKCS#5、PKCS#7、PKCS#8、PKCS#10、PKCS#12
  • 楕円曲線暗号:Brainpool 楕円曲線(RFC 5639、RFC 6932)、ECDSA(RFC 4754)、ECP グループ(RFC 5903)、楕円曲線デジタル署名(ECDS)
  • IKE および TLS 鍵導出関数
  • 乱数生成: NIST SP 800-90A Rev 1: AES-CTR
  • エントロピーソース ENT(NP) は NIST SP 800-90B に準拠しています

対応デバイス・対応OS

ベアメタル・各種OS

ライセンス形態

弊社にお問い合わせください。

評価版

弊社にお問い合わせください。

INQUIRY

FIPS 暗号ライブラリ(SafeZone 暗号ライブラリ)に関する在庫、価格などの
お問い合わせはこちらから

フォームが表示されるまでしばらくお待ち下さい。

恐れ入りますが、しばらくお待ちいただいてもフォームが表示されない場合は、こちらまでお問い合わせください。

お急ぎの方はこちらから
050-3000-2102
平日:9:00〜17:00
CONTACT

まずは、ご相談ください。

「探している組み込み製品」も「相談したい組み込み開発」も、まずはこちらから。
“こんな製品はないか”、“見積もりがほしい”、“この技術は対応できるか”、“詳しい実績が知りたい”——質問だけでも結構です。
お急ぎの場合も迅速に対応します。

お電話でのお問い合わせ 050-3000-2102 インダストリービジネス事業部 平日:9:00〜17:00