HOME/組み込み製品/半導体IP/汎用IP/耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum)
セキュリティ

耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum)

SASE・VPN機器向けの耐量子IPsecソフト実装。ML-KEM対応、FIPS 140-3暗号モジュールと統合可

メーカー Rambus Rambus
耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum) 製品画像
製品名
耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum)
スペシフィケーション
IPsec、PQC

概要・特徴

Quantum Safe IPsec Toolkit (QuickSec Quantum) は、Quantum Safe 暗号化をサポートする、市場初の完全な IPsec ソフトウェア実装です。Quantum Safe 暗号化は、量子コンピュータによる攻撃に耐えるよう設計されており、最新のセキュリティ製品に必須の機能です。
Quantum Safe IPsec Toolkit は、Rambus Classic IPsec Toolkit の実績、経験、パフォーマンスを基盤とし、IPsec を量子安全の時代へと導きます。サーバーとクライアントがあらゆる種類のクライアント/サーバーデバイスと通信し、既存のネットワークと相互運用する必要がある場合に、関連するすべての(100を超える)RFCおよび標準規格をサポートする、完全で高度にスケーラブルなIPsec実装です。Linuxデータプレーン(カーネル依存なし)は、物理環境または仮想環境における高トラフィック展開に最適です。
Quantum Safe IPsec Toolkit は、FIPS 140-3 認証済みの暗号モジュールとオプションで統合可能で、物理的および仮想クラウド/ネットワーク製品、SASE、SD-WAN、プリンター、組み込みデバイスなどのベンダーに適しています。
Rambusの IPsec 実装は、開発コストを最小限に抑え、市場投入までの時間を最短化します。IPsec の複雑な部分をすべて管理し、常に最新状態を維持するため、お客様はエンド製品に集中できます。

動作説明

Quantum Safe IPsec ツールキットの動作
QuickSec Quantum はモジュール式に設計されていますが、全体としてシームレスに動作します。2 つの実行時設定オプション(C API および XML 設定ファイル)を提供し、IKE ライブラリ、データプレーン API、ポリシーマネージャー API などの複数の統合ポイントを備えています。
弊社の顧客が、さまざまな他のIPsec実装とシームレスに動作する製品を開発する際、Quantum Safe IPsec Toolkitは、QAプロセスの一環として相互運用性と互換性について徹底的にテストされています。
高度な機能:
高いセッション設定速度。8 コア CPU で 2 回の鍵交換ラウンド(ML-KEM-768 および ECDH)により、1 秒あたり 3800 以上の IPsec トンネルを確立可能。マルチコアアーキテクチャで優れたスケーラビリティを発揮します。
トンネル数は、利用可能なコンピューティングリソースによってのみ制限されます。
高可用性(HA)。RFC 6311に基づくネイティブクラスタリング実装またはIKEとIPsec SAのインポート/エクスポートAPIを使用してHAを実現できます。
簡単なデバッグ。大規模展開時の問題解決のため、パフォーマンスに影響を与えずに特定のトンネルの詳細ログを要求できます。
マルチテナント:複数のネットワークまたは複数のオペレーターをサポートするeNodeB向けに、独立したオーバーラップ可能な仮想ルーティングとフォワーディング(VRF)インスタンスをサポートします。
汎用データプレーンAPI。Quantum Safe IPsec Toolkitは、LinuxカーネルのIPsecデータプレーンまたは同じAPIをサポートする他のデータプレーンと統合可能です。さらに、上位の汎用データプレーンAPIにより、任意のIPsecデータプレーンとの統合が可能です。
外部暗号化API。このAPIにより、サードパーティのハードウェア(HSM)またはソフトウェア暗号化モジュールを使用可能です。
IPsec境界。IPsec境界を定義することで、カーネルでセキュリティポリシーを強制適用し、パケットがセキュリティポリシーを違反しないようにします。
主要企業は、QuickSecをクラウド、SASE、SD-WAN、エンタープライズセキュリティゲートウェイ、高セキュリティ政府機関向けアプライアンス、高容量キャリアゲートウェイ、eNodeB、組み込みデバイス、プリンターなどの実装に採用しています。

耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum)

仕様

機能

  • 完全な IPsec および IKE クライアント/サーバー ツールキット
  • 耐量子暗号および RFC
  • 高い相互運用性と標準準拠
  • アクティブ/スタンバイ クラスタリングによる高可用性
  • 市場最速の IKE 実装で、トンネル設定速度は他を凌駕。QuickSec 10 より 15% 高速です。
  • スケーラビリティ:100万件以上のIPsecトンネル展開に対応
  • FIPS 140-3認証済みの暗号モジュールを搭載
  • GPL制約のない、明確で高移植性のCソースコードで実装
  • ルーティングインスタンスでマルチテナント対応のトラフィック隔離
  • 幅広いハードウェアおよびソフトウェアプラットフォーム対応
  • GPLライセンスのオープンソースソフトウェアのより優れた商用代替品
  • エンジニアレベルサポートと定期的なアップデートをメンテナンス契約で提供
  • ソースコード形式で提供(変更権限付き)

IKE(インターネットキー交換)サポート

  • IKEv2(RFC 7296)、IKEv2 フラグメンテーション(RFC 7383)、IKEv2 リダイレクト(RFC 5685)
  • 複数キー交換(RFC 9370)および IKEv2 における中間交換(RFC 9242)
  • ML-KEM(FIPS 203)
  • ML-DSA(FIPS 204)署名認証および証明書用)
  • 高可用性(RFC 6311)
  • トンネルおよびトランスポートモード
  • サイト間 VPN
  • マルチテナント(VRF) – 複数の仮想ルーティングおよびフォワーディングインスタンス
  • 署名認証(RFC 7427)
  • MOBIKE(RFC 4555、RFC 4621)
  • IKEv1 メインモードおよびアグレッシブモード
  • 完全前方秘匿性(PFS)オプション
  • デッドピア検出(DPD)、NAT トラバーサル(NAT-T)
  • 認証:事前共有鍵 (PSK)、XAUTH、証明書 (完全な PKI サポート)、拡張認証プロトコル (EAP-SIM、EAP-AKA、EAPMD5)、RADIUS、複数認証 (RFC 4739)
  • IPv4 および IPv6 サポート: IPv4 over IPv6、IPv6 over IPv4、IPv6 over
  • IPv6、DHCPv4 および DHCPv6
  • RSA、DSA および ECDSA 公開鍵アルゴリズム (IKE 署名モードのみ)
  • NIST 特別公開 800-131A に準拠した IKE における SHA2 対応 RSA 署名サポート
  • RSASSA-PSS 署名方式
  • Diffie-Hellman 鍵交換アルゴリズム
  • FIPS 140-3 認証暗号化をオプションの商用オプションとして提供
  • リモートアクセスサポート: サーバーで構成された仮想アダプター
  • 組み込みの IP アドレス割り当て
  • 汎用 Raw 公開鍵 (RFC 7670) – RSA、DSA、ECDSA
  • RFC 8784 – IKEv2 における事前共有鍵の混合による量子耐性セキュリティ

証明書およびPKI機能

  • X.509v3 (PKIX) 証明書プロファイルサポート
  • X.509v3 (PKIX) 証明書失効リスト (CRL) サポート
  • 証明書配布ポイントサポート(LDAPおよびHTTP対応)
  • OCSPを使用したオンライン証明書ステータス確認
  • NIST特別公開文書800-131Aに準拠した証明書内のSHA2に対するRSA署名サポート
  • 完全な IPsec 暗号化
  • 暗号アルゴリズム:AES、AES-CTR、AES-CCM、AES-GCM、AES-GCM-64、GMAC-AES、3DES
  • MAC アルゴリズム:SHA-1、SHA-2、GMAC-AES、AES-XCBC

非対称暗号アルゴリズム:ML-KEM、ML-DSA、RSA、Diffie-Hellman、ECC DH、ECC DSA、PKCS#1、PKCS#5、PKCS#7、PKCS#8、PKCS#10、PKCS#12

  • 楕円曲線暗号:Brainpool 楕円曲線(RFC 5639、RFC 6932)、ECDSA(RFC 4754)、ECP グループ(RFC 5903)

対応デバイス・対応OS

ベアメタル・各種OS

ライセンス形態

弊社にお問い合わせください。

評価版

弊社にお問い合わせください。

INQUIRY

耐量子暗号IPSecツールキット Quantum Safe IPsec Toolkit (QuickSec Quantum)に関する在庫、価格などの
お問い合わせはこちらから

フォームが表示されるまでしばらくお待ち下さい。

恐れ入りますが、しばらくお待ちいただいてもフォームが表示されない場合は、こちらまでお問い合わせください。

お急ぎの方はこちらから
050-3000-2102
平日:9:00〜17:00
CONTACT

まずは、ご相談ください。

「探している組み込み製品」も「相談したい組み込み開発」も、まずはこちらから。
“こんな製品はないか”、“見積もりがほしい”、“この技術は対応できるか”、“詳しい実績が知りたい”——質問だけでも結構です。
お急ぎの場合も迅速に対応します。

お電話でのお問い合わせ 050-3000-2102 インダストリービジネス事業部 平日:9:00〜17:00