HOME/組み込み製品/半導体IP/汎用IP/耐量子暗号ライブラリ(Quantum Safe Crypto Library)
セキュリティ

耐量子暗号ライブラリ(Quantum Safe Crypto Library)

耐量子(ML-KEM/ML-DSA/LMS/XMSS)と従来暗号を1つにまとめたソフト暗号ライブラリ。各種OS対応

メーカー Rambus Rambus
耐量子暗号ライブラリ(Quantum Safe Crypto Library) 製品画像
製品名
耐量子暗号ライブラリ(Quantum Safe Crypto Library)
スペシフィケーション
PQC

概要・特徴

Rambusの Quantum Safe Crypto Library(SafeZone Quantum Safe Crypto Library)は、パフォーマンスと信頼性に重点を置いた、耐量子暗号(PQC)時代向けの暗号アルゴリズムを提供します。

動作説明

Quantum Safe Crypto Library は、以下の耐量子アルゴリズムおよびスキームを実装しています:

  • ML-KEM (CRYSTALS-Kyber) – 鍵カプセル化メカニズム
  • ML-DSA (CRYSTALS-Dilithium) – デジタル署名スキーム
  • LMS – 状態保持型ハッシュベース署名スキーム
  • XMSS – 状態保持型ハッシュベース署名スキーム

計画中:

  • SLH-DSA(SPHINCS+ ベース) – ステートレスハッシュベースの署名方式

Falcon – 署名方式
さらに、このライブラリには、すべての古典的な暗号アルゴリズムが含まれています:
暗号アルゴリズム:AES、AES-CCM、AES-GCM、AES-GCM-64、GMAC-AES、3DES
MAC アルゴリズム: SHA-1、SHA-2、GMAC-AES、AES-XCBC
非対称暗号アルゴリズム: RSA、Diffie-Hellman、ECC DH、ECC DSA、PKCS#1、PKCS#5、PKCS#7、PKCS#8、PKCS#10、PKCS#12
楕円曲線暗号: Brainpool 楕円曲線 (RFC 5639、RFC 6932)、ECDSA (RFC 4754)、ECP グループ (RFC 5903)、楕円曲線デジタル署名 (ECDS)
IKE および TLS 鍵導出関数。
乱数生成: NIST SP 800-90A Rev 1: AES-CTR

対応デバイス・対応OS

ベアメタル・各種OS

ライセンス形態

弊社にお問い合わせください。

評価版

弊社にお問い合わせください。

INQUIRY

耐量子暗号ライブラリ(Quantum Safe Crypto Library)に関する在庫、価格などの
お問い合わせはこちらから

フォームが表示されるまでしばらくお待ち下さい。

恐れ入りますが、しばらくお待ちいただいてもフォームが表示されない場合は、こちらまでお問い合わせください。

お急ぎの方はこちらから
050-3000-2102
平日:9:00〜17:00
CONTACT

まずは、ご相談ください。

「探している組み込み製品」も「相談したい組み込み開発」も、まずはこちらから。
“こんな製品はないか”、“見積もりがほしい”、“この技術は対応できるか”、“詳しい実績が知りたい”——質問だけでも結構です。
お急ぎの場合も迅速に対応します。

お電話でのお問い合わせ 050-3000-2102 インダストリービジネス事業部 平日:9:00〜17:00